Задать вопрос
14 апреля, 00:39

Написать программу, ведущую учет очков, набранных каждой командой при игре в баскетбол. Количество очков, полученных командами в ходе игры, может быть равно 1, 2 или 3. После окончания игры выдать итоговое сообщение и указать номер команды-победительницы. Окончание игры условно моделировать вводом количества очков, равного нулю. На паскаль

+2
Ответы (2)
  1. 14 апреля, 03:47
    0
    var

    commands: array [1 ... 2] of byte;

    buf: string;

    begin

    writeln ('Формат ввода: (№ комманды) (пробел) (очки) ') ;

    writeln ('Например: 1 3') ;

    writeln ('№ О') ;

    repeat

    readln (buf) ;

    if buf = '0' then break;

    commands[integer. Parse (buf[1]) ] + = byte. Parse (buf[3]) ;

    until false;

    writeln (String. Format ('Команда {0} победила во счётом {1} очк.', commands[1] > commands[2]? 1 : 2, max (commands[1], commands[2]))) ;

    end.
  2. 14 апреля, 04:30
    0
    Полный код не влез, в 2 комента вставил
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Написать программу, ведущую учет очков, набранных каждой командой при игре в баскетбол. Количество очков, полученных командами в ходе игры, ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы