Задать вопрос
24 декабря, 02:26

Pascal

Выведите все числа на отрезке от a до b, являющиеся полными квадратами.

Примеры:

Входные данные

1

5

Выходные данные

1 4

+2
Ответы (1)
  1. 24 декабря, 04:12
    0
    Var a, b, i:integer;

    x:real;

    Begin

    Readln (a) ;

    Readln (b) ;

    If a<0 Then a:=1;

    For i:=a to b do

    Begin

    x:=sqrt (i) ;

    If frac (x) = 0 Then Write (i,' ') ;

    End;

    End.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Pascal Выведите все числа на отрезке от a до b, являющиеся полными квадратами. Примеры: Входные данные 1 5 Выходные данные 1 4 ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы