Задать вопрос
13 января, 09:18

Составить программу решения ах2+вх+с=0, а, в не равно нулю. Проверить случай, когда дискриминант болmше нуля меньше нуля и равен нулю.

+5
Ответы (1)
  1. 13 января, 12:25
    0
    program ii;

    var A, B, C, D: real;

    begin

    writeln ('Введите коэффициенты А, В, С') ;

    readln (A, B, C) ;

    if A=0 then

    writeln ('Уравнение не квадратное')

    else

    begin

    D : = B*B - 4*A*C;

    A : = 2*A;

    if D<0 then

    writeln ('Действительных корней нет')

    else

    if D=0 then

    writeln ('Корни равны: X1 = X2 = ', - B/A)

    else

    begin

    D : = sqrt (D) ;

    writeln ('X1 = ', (-B+D) / A) ; writeln ('X2 = ', (-B-D) / A) ;

    end; end; end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Составить программу решения ах2+вх+с=0, а, в не равно нулю. Проверить случай, когда дискриминант болmше нуля меньше нуля и равен нулю. ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы