Задать вопрос
2 сентября, 13:51

Составить программу (полный текст программы) вычисления стоимости покупки с учетом скидки. Скидка в 3% предоставляется, если сумма покупки больше 500 руб, в 5% - если сумма больше 1000 руб. Фрагмент программы: if x>500 then y:=0.97*x; if x>1000 then y:=0.95*x;

+3
Ответы (1)
  1. 2 сентября, 17:40
    0
    var

    x: real;

    begin

    readln (x) ;

    if (x > 500) then x : = 0.97 * x

    else if (x > 1000) then x : = 0.95 * x;

    writeln ('Стоимость покупки с учетом скидки: ', x) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Составить программу (полный текст программы) вычисления стоимости покупки с учетом скидки. Скидка в 3% предоставляется, если сумма покупки ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы