Задать вопрос
6 марта, 13:12

В городе N-ске проходит конкурс на звание "Мистер большой живот". Побеждает тот, у кого объем талии больше всего. Помогите определить объем талии золотого и серебряного призера, если известно количество участников и объем талии каждого из них (все размеры талий различны)

Формат ввода N - кол-во участников Больше 3, меньше 100 А[1] объем талии первого участника А[N] объем талии N-ого участника (90<=А[N<=1000]).

Формпт вывода: два числа K1, K2 - объем талии золотого и серебрянного призера

Пример ввода 89 60 78 45 65 99 78

Пример вывода 99 89

+4
Ответы (1)
  1. 6 марта, 17:00
    0
    Program gt;

    var n, i, j, l:integer;

    a:array[1 ... 1000]of integer;

    begin

    readln (n) ;

    for i:=1 to n do

    read (a[i]) ;

    for i:=1 to n-1 do

    for j:=1 to n-1 do

    if (a[j]
    l:=a[j]; a[j]:=a[j+1];

    a[j+1]:=l;

    end;

    writeln (a[1],' ', a[2]) ;

    end.

    Я просто отсортировал массив по убыванию методом пузырка
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «В городе N-ске проходит конкурс на звание "Мистер большой живот". Побеждает тот, у кого объем талии больше всего. Помогите определить объем ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы