Задать вопрос
9 марта, 14:12

В Паскале

Составьте программу, определяющую название дня недели по его номеру: 1 - Понедельник, 2 - Вторник и т. д. При вводе числа вне диапазона [1 ... 7] программа должна выдать сообщение об ошибке

+4
Ответы (1)
  1. 9 марта, 17:16
    0
    Var x: byte;

    Begin

    Write (‘ введите число от 1 до 7')

    Readln (x) ;

    Case x of

    1: writeln (‘понедельник’) ;

    2: writeln (‘вторник’) ;

    3: writeln (‘среда’) ;

    4: writeln (‘четверг’) ;

    5: writeln (‘пятница’) ;

    6: writeln (‘суббота’) ;

    7: writeln (‘воскресенье’) ;

    end;

    Readln

    End.

    я не помню как чтоб выдало ошибку ... пили если больше х то ошибка
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «В Паскале Составьте программу, определяющую название дня недели по его номеру: 1 - Понедельник, 2 - Вторник и т. д. При вводе числа вне ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы