Задать вопрос
21 июня, 20:46

Составить программу в Паскаль АВС

Найти среднее арифметическое элементов массива. Найти сумму элементов массива, которые меньше среднего арифметического.

+5
Ответы (1)
  1. 21 июня, 22:12
    0
    Const

    maxN = 100; / / Максимальное кол-во элементов массива

    var

    n, i: longint;

    middle, sum, sum2: real; / / Может быть нецелым числом

    a: array[1 ... maxN] of real;

    begin

    write ('Введите количество элементов массива: ') ;

    readln (n) ;

    sum : = 0; / / Считаем сумму всех элементов, чтобы найти среднее арифметическое

    write ('Введите элементы массива через пробел: ') ;

    for i : = 1 to n do begin

    read (a[i]) ;

    sum : = sum + a[i];

    end;

    middle : = sum / n; / / Вычисляем среднее арифметическое

    writeln ('Среднее арифметическое = ', middle) ;

    sum2 : = 0; / / Считаем сумму элеметов, меньших среднего арифметического

    for i : = 1 to n do

    if a[i] < middle then

    sum2 : = sum2 + a[i];

    writeln ('Сумма элементов, меньших среднего арифметического = ', sum2) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Составить программу в Паскаль АВС Найти среднее арифметическое элементов массива. Найти сумму элементов массива, которые меньше среднего ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы