Задать вопрос
21 апреля, 19:40

Написать программу в Паскале!

Указание: Заполнить двумерный числовой массив И (8,8) случайными целыми числами в интервале [-60,60]. Написать единую программу для всех задач, ответ каждой задачи выводить с новой строки.

Задача 1: Найдите среднее арифметическое отрицательных элементов 3 строки.

Задача 2: Обнулите элементы, имеющие четное значение и стоящие на побочной диагонали.

Задача 3: Создайте новый одномерный массив из элементов, имеющих значение больше - 5.

Задача 4: Определите максимальный элемент массива в первом столбике.

Задача 5: Вычислить сумму элементов в каждой строке массива.

+5
Ответы (1)
  1. 21 апреля, 22:17
    0
    Const n=3;

    var a:array[1 ... n, 1 ... n] of integer;

    ss:array[1 ... n] of integer;

    i, j, s, k, max:integer; sr:real;

    begin

    writeln ('Исходный массив: ') ;

    for i:=1 to n do

    for j:=1 to n do a[i, j]:=random (121) - 60;

    for i:=1 to n do begin

    for j:=1 to n do write (a[i, j]:5) ;

    writeln;

    end;

    for i:=1 to n do

    for j:=1 to n do

    if (i=3) and (a[i, j]<0) then begin

    s:=s+a[i, j];

    k:=k+1;

    end;

    sr:=s/k;

    writeln ('Ср. арифм. отрицательных элементов 3 строки: ', sr) ;

    writeln ('После обнуления: ') ;

    for i:=1 to n do

    for j:=1 to n do

    if (j=n-i+1) and (a[i, j] mod 2=0) then a[i, j]:=0;

    for i:=1 to n do begin

    for j:=1 to n do write (a[i, j]:5) ;

    writeln;

    end;

    writeln ('Одномерный массив из элементов, имеющих значение больше - 5: ') ;

    for i:=1 to n do

    for j:=1 to n do

    if (a[i, j]>-5) then write (a[i, j],' ') ;

    writeln;

    writeln ('Максимальный элемент массива в 1 стоблце: ') ;

    max:=a[1,1];

    for i:=1 to n do

    for j:=1 to n do

    if a[i, 1]>max then max:=a[i, 1];

    write (max) ;

    writeln;

    writeln ('Сумма элементов в каждой строке массива: ') ;

    for i:=1 to n do

    ss[i]:=0;

    for i:=1 to n do

    for j:=1 to n do

    ss[i]:=ss[i]+a[i, j];

    for i:=1 to n do write (ss[i]:5) ;

    writeln;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Написать программу в Паскале! Указание: Заполнить двумерный числовой массив И (8,8) случайными целыми числами в интервале [-60,60]. ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы