Задать вопрос
5 декабря, 15:46

Написать программу на языке Pascal: Задача: Вводятся целые числа до первого числа, которое меньше двух. Определить, сколько простых чисел было введено. Описание переменных: q - счетчик простых чисел; n - очередное введенное число. Алгоритм решения задачи: Пока введенное число больше 1, проверять его на простоту по следующему алгоритму: Если число делится на любой делитель от 2 до половины от себя, то оно не простое. Если число так и не разделилось ни на один из перебранных делителей, то оно простое, следовательно, увеличиваем счетчик простых чисел.

+2
Ответы (1)
  1. 5 декабря, 18:20
    0
    Var q, n, i, k, h:integer;

    begin

    readln (n) ;

    h:=1;

    while n>1 do

    begin

    k:=n div 2;

    for i:=2 to k do

    if n mod i=0 then h:=0;

    q:=q+h;

    h:=1;

    readln (n) ;

    end;

    writeln ('Простых чисел: ', q)

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Написать программу на языке Pascal: Задача: Вводятся целые числа до первого числа, которое меньше двух. Определить, сколько простых чисел ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы