Задать вопрос
7 марта, 19:05

Дано натуральнок K от 1 до 180. Написать программу для определения цифры, которая находится в k-той позиции последовательности 10111213 ... 9899. Формат входных данных Файл содержит число k-позиция искомой цифры. Формат выходных данных Выходной файл содержит искомую цифру. Пример входных и выходных файлов Task1. in Task1. out 4 1 8 3

+2
Ответы (1)
  1. 7 марта, 21:04
    0
    Var k: integer;

    f: Text;

    begin

    assign (f, 'Task1. in') ;

    reset (f) ;

    readln (f, k) ;

    close (f) ;

    assign (f, 'Task1. out') ;

    rewrite (f) ;

    if (k mod 2 = 0) then

    writeln (f, ((k-1) div 2) mod 10)

    else

    write (f, (k div 2) div 10 + 1) ;

    close (f) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Дано натуральнок K от 1 до 180. Написать программу для определения цифры, которая находится в k-той позиции последовательности 10111213 ... ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы