Задать вопрос
9 июля, 19:23

Написать программу, которая заменяет все заглавные буквы строчными, а строчные - заглавными в заданной символьной строке. (Паскаль)

+4
Ответы (1)
  1. 9 июля, 22:06
    0
    Program X; / / работает только для русских строк

    var

    i: longint;

    s: string;

    begin

    readln (s) ;

    for i : = 1 to length (s) do

    if (ord (s[i]) > = 192) and (ord (s[i]) < = 223) then

    s[i] : = chr (ord (s[i]) + 32)

    else if (ord (s[i]) > = 224) and (ord (s[i]) < = 255) then

    s[i] : = chr (ord (s[i]) - 32) ;

    writeln (s)

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Написать программу, которая заменяет все заглавные буквы строчными, а строчные - заглавными в заданной символьной строке. (Паскаль) ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы