Задать вопрос
25 января, 20:27

Тема:Pascal. Циклы

1) Составить программу подсчета суммы нечетных делителей, кратных трем, натурального числа N

2) Составить программу, вычисляющую x^n, где n-целое положительное число.

3) Одноклеточная амеба каждые 3 часа делится на 2 клетки. Определить, сколько амеб будет через 3,6,9,12 ... 24 часа.

+5
Ответы (1)
  1. 25 января, 21:55
    0
    1

    var n, s, i:integer;

    begin

    readln (n) ;

    for i:=3 to n do

    if (n mod i=0) and (i mod 3=0) and (i mod 2>0) then

    s:=s+i;

    writeln ('Ответ: ', s) ;

    end.

    2

    var

    n, i:integer;

    x, y:real;

    begin

    readln (x, n) ;

    y:=1;

    for i:=1 to n do y:=y*x;

    writeln (x,'^', n,'=', y) ;

    end.

    3

    var n, i:integer;

    begin

    n:=1;

    writeln ('Часы ',' Кол-во') ;

    while i<25 do

    begin

    writeln (i:3, n:6) ;

    n:=n*2;

    i:=i+3;

    end;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Тема:Pascal. Циклы 1) Составить программу подсчета суммы нечетных делителей, кратных трем, натурального числа N 2) Составить программу, ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы