Задать вопрос
24 августа, 05:13

1) дано целое число N (больше 0). Найти сумму 1+1/2+1/3 ... 1/N (вещественное число). Входные данные: ввести целое числоN (1<=n<=20)

Выходные данные: вывести сумму 1+1/2=1/3 + ... 1N с точностью до 4 цифр в дробной части. (в паскале)

+5
Ответы (1)
  1. 24 августа, 08:35
    0
    var H: real;

    N, i: integer;

    begin

    H : = 0;

    readln (N) ;

    for i : = 1 to N do

    H : = H + 1/i;

    writeln (H:6:4)

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «1) дано целое число N (больше 0). Найти сумму 1+1/2+1/3 ... 1/N (вещественное число). Входные данные: ввести целое числоN (1 ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы