Задать вопрос
29 сентября, 11:48

Программисту поставили задачу написать программу, которая по введённому натуральному числу n должна выводить через пробел все нечётные числа из диапазона от 1 до n. Программист торопился и написал следующую программу:

program error;

var

n, i: integer;

begin;

write ('9') ;

readln (n) ;

for i : = 1 to 9 do

if (i mod 2 = 0) then write (i) ;

writeln

end.

С помощью откладки найдите и исправьте допущенные ошибки.

+3
Ответы (1)
  1. 29 сентября, 13:21
    0
    Program error;

    var

    n, i: integer;

    begin;

    write ('Введите натуральное число n = ') ;

    readln (n) ;

    for i : = 1 to n do

    if (i mod 2 = 1) then write (i,' ') ;

    writeln

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Программисту поставили задачу написать программу, которая по введённому натуральному числу n должна выводить через пробел все нечётные ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы