Задать вопрос
11 сентября, 16:09

Написать

программу, которая спрашивает "Который час?" и, в зависимости от введенного

времени, выводит на экран приветствие: "Доброе утро", "Добрый день", "Добрый

вечер", "Спокойной ночи".

+2
Ответы (1)
  1. 11 сентября, 18:12
    0
    Program z1;

    var a:real;

    begin

    writeln ('Который час?') ;

    read (a) ;

    if (a>=6) and (a<12) then writeln ('Доброе утро') else

    begin

    if (a>11) and (a<=16) then writeln ('Добрый день') else

    begin

    if (a>16) and (a<=22) then writeln ('Добрый вечер') else

    begin

    if (a>22) or (a<6) then writeln ('Спойкойной ночи') end; end; end;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Написать программу, которая спрашивает "Который час?" и, в зависимости от введенного времени, выводит на экран приветствие: "Доброе утро", ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы