Задать вопрос
2 декабря, 18:46

Элементы заданной матрицы A (m, n) - целые числа. Напишите программу вычисляющую сумму и произведения элементов, которые кратны 3 или 2.

+1
Ответы (1)
  1. 2 декабря, 20:17
    0
    Var

    a : array [1 ... 100,1 ... 100] of longint;

    n, m, i, j, sum, mnj : longint;

    begin

    readln (n, m) ;

    for i:=1 to n do

    for j:=1 to m do read (a[i, j]) ;

    sum:=0;

    mnj : = 1;

    for i:=1 to n do

    for j:=1 to m do

    if (a[i, j] mod 3) = 0 or ((a[i, j] mod 2) = 0) then begin sum:=sum+a[i, j]) ; mnj:=mnj*a[i, j]; end;

    writeln (sum,' ', mnj) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Элементы заданной матрицы A (m, n) - целые числа. Напишите программу вычисляющую сумму и произведения элементов, которые кратны 3 или 2. ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы