Задать вопрос
26 апреля, 06:03

Написать программу для паскаль. С клавиатуры вводятся целые числа. Признаком конца ввода является 0. Изменить знак отрицательных чисел на противоположный. Результаты вывести на экран.

+5
Ответы (2)
  1. 26 апреля, 07:23
    0
    Var n: integer;

    s: string;

    begin

    writeln ('Вводите числа') ;

    repeat

    readln (n) ;

    s: = s + IntToStr (abs (n)) + ' '

    until n = 0;

    writeln (s) ;

    end.
  2. 26 апреля, 08:35
    0
    Предложу решение, основанное на том, что понял из текста)

    var a: integer;

    begin

    writeln ('Вводите числа') ;

    a:=1;

    while a0 do begin

    readln (a) ;

    if a<0 then writeln ('Противоположное число ', abs (a)) ;

    end;

    readln

    end.

    Можно их в массив записывать, если нужно вывести красиво.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Написать программу для паскаль. С клавиатуры вводятся целые числа. Признаком конца ввода является 0. Изменить знак отрицательных чисел на ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы