Задать вопрос
18 октября, 06:35

Задача:

Подсчитать сумму 1! + 2! + 3! + ... N!

Где, например, 5! - - факториал числа 5 и 5! = 1*2*3*4*5

Формат ввода:

На вход подается натуральное число n не превосходящих 10.

Формат вывода:

Целое число - результат вычисления формулы.

Пример входных данных

5

Пример выходных данных

153

+5
Ответы (1)
  1. 18 октября, 07:34
    0
    Function Factorial (N: integer) : integer;

    var i, R: integer;

    begin

    R : = 1;

    For i: = 1 to N do

    R : = R * i;

    Factorial : = R;

    end;

    Var

    N, i, S: integer;

    Begin

    ReadLn (N) ;

    S : = 0;

    For i: = 1 to N do

    S : = S + Factorial (i) ;

    WriteLn (S) ;

    End.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Задача: Подсчитать сумму 1! + 2! + 3! + ... N! Где, например, 5! - - факториал числа 5 и 5! = 1*2*3*4*5 Формат ввода: На вход подается ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы