Задать вопрос
24 марта, 15:59

Ввести с клавиатуры массив из N вещественных чисел. Найти разность максимального и минимального элементов.

(Составить программу Pascal)

+5
Ответы (1)
  1. 24 марта, 16:28
    0
    Uses crt;

    const

    N = 10;

    var

    a : array [1 ... N] of Real;

    i : Integer;

    max, min : Real;

    begin

    clrscr;

    for i : = 1 to N do

    begin

    Write ('a[', i,'] = ') ;

    Readln (a[i]) ;

    end;

    max : = a[1];

    min : = a[1];

    for i : = 2 to N do

    begin

    if max < a[i] then max : = a[i];

    if min > a[i] then min : = a[i];

    end;

    Writeln (max - min:0:3) ;

    Readln;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Ввести с клавиатуры массив из N вещественных чисел. Найти разность максимального и минимального элементов. (Составить программу Pascal) ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы