Задать вопрос
25 июля, 06:47

Ваш друг предлагает вам переписать отснятый им видеофильм. Из носителей информации у вас есть: компакт-диск объемом 650 МБ, дискета объемом 1 МБ и флеш-накопитель объемом 1000 Мб. Напишите программу, перечисляющую все носители, на которые полностью поместится фильм. Объем видеофайла задается в мегабайтах.

+3
Ответы (1)
  1. 25 июля, 09:55
    0
    Var

    d:integer;

    const

    a=650;

    b=1;

    c=1000;

    begin

    write ('Введите объём видеофайла в мегабайтах: ') ;

    readln (d) ;

    if d>a then write ('Видеофайл не помещается на носитель информации"А"!',#10) else

    writeln ('Памяти хватает для записи на носитель "А"! ',#10) ;

    if d>b then write ('Видеофайл не помещается на носитель информации"B"!',#10) else

    writeln ('Памяти хватает для записи на носитель "B"! ',#10) ;

    if d>c then write ('Видеофайл не помещается на данный носитель информации"С"!',#10) else

    writeln ('Памяти хватает для записи на носитель "C"! ',#10) ;

    readln;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Ваш друг предлагает вам переписать отснятый им видеофильм. Из носителей информации у вас есть: компакт-диск объемом 650 МБ, дискета объемом ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы