Задать вопрос
5 мая, 17:11

Дан массив, состоящий из целых чисел. Известно, что числа упорядочены по неубыванию (то есть каждый следующий элемент не меньше предыдущего). Напишите программу, которая определит количество различных чисел в этом массиве.

Входные данные

Сначала задано число N - количество элементов в массиве (1N100). Далее через пробел записаны N чисел - элементы массива. Массив состоит из целых чисел.

Выходные данные

Необходимо вывести единственное число - количество различных чисел в массиве.

Примеры

Входные данные

5

1 1 1 1 1

Выходные данные

1

+1
Ответы (1)
  1. 5 мая, 20:19
    +1
    Program X;

    var

    mas: array[1 ... 1000000] of longint;

    N, i, count:longint;

    begin

    count:=1;

    readln (N) ;

    for i:=1 to N do

    read (mas[i]) ;

    if N>1 then

    begin

    for i:=2 to N do

    if mas[i]mas[i-1] then inc (count) ;

    writeln (count)

    end

    else

    writeln (1)

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Дан массив, состоящий из целых чисел. Известно, что числа упорядочены по неубыванию (то есть каждый следующий элемент не меньше ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы