Задать вопрос
1 сентября, 13:54

1. Написать программу, решающую уравнение ax=b. Предусмотреть все варианты для значений a и b.

2. Идет к-ая секунда суток. Определить, сколько целых часов и целых минут прошло с начала суток. На экран вывести фразу: "It is ... hours ... minutes".

3. Вводится пятизначное число. Найти сумму цифр этого числа.

Написать программы в паскале.

+3
Ответы (1)
  1. 1 сентября, 14:17
    0
    1.

    program simple;

    var a, b:integer;

    begin

    writeln ('daite a, b) ; readln (a, b) ;

    writeln ('x = ', b/a) ; readln;

    end;

    2.

    program day;

    var h, hours, minutes:longint;

    begin

    writeln ('daite secundi') ; readln (h) ;

    hour: = h div 3600; minutes:=h mod 36000;

    if (minutes > 60) or (minutes=60) then

    begin

    hour:=hour+1;

    minutes:=minutes-60;

    end;

    writeln ('It is 'hours' hours 'minutes' minutes') ;

    readln;

    end;

    3.

    program summaChisla;

    var s:string; i, sum: longint; c, cod:integer;

    begin

    writeln ('daite nomer) ; readln (s) ;

    for i:=1 to length (s) do

    begin

    val (s[i], c, cod) ; sum:=sum+c;

    end;

    writeln ('summa : ', sum) ; readln;

    end;
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «1. Написать программу, решающую уравнение ax=b. Предусмотреть все варианты для значений a и b. 2. Идет к-ая секунда суток. Определить, ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы
Похожие вопросы по информатике
Напишите задачи в Паскале задача1 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ... 1000000] Вывести на экран их произведение.} задача2 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ...
Ответы (2)
1. Пользователем вводится целое число. Вывести на экран последовательность целых чисел от единицы до этого числа. 2. Вывести на экран 10 строк, содержащие символ *, причем количество * в каждой строке должно быть равно номеру строки. 3.
Ответы (1)
Идет i-ая секунда суток. Напишите программу, которая по введенной i-ой секунде суток определит, сколько целых часов h, целых минут min и секунд с прошло с начала суток. Например: 13257 секунд = 3 часа 40 минут и 57 секунд.
Ответы (1)
Идет k-я секунда суток. Определить, сколько целых часов (H) и целых минут (M) прошло с начала суток. Вывести на экран фразу: "Это ... часов ... минут". Вместо многоточий поставить вычисленные значения Н и М. (! На Питоне!)
Ответы (1)
Паскаль. 1. вывести на экран все четные числа от 1 до n. 2. вывести на экран все трехзначные числа. 3. вывести на экран четырехзначные числа оканчивающийся на 7. 4. вывести на экран все трехзначные и двухзначные числа сумма цифр которых равна девяти.
Ответы (1)