Задать вопрос
29 января, 01:26

Написать программу, которая в заданном одномерном массиве размерности N меняет местами соседние элементы, стоящие на чётных местах, с соседними элементами, стоящими на нечётных местах.

+5
Ответы (1)
  1. 29 января, 04:09
    0
    var a:array[1 ... 10] of integer;

    i, tmp:integer;

    begin cls;

    for i:=1 to 10 do a[i]:=i;

    for i:=1 to 10 do

    begin

    if i mod 2 = 1 then

    begin

    tmp:=a[i];

    a[i]:=a[i+1];

    a[i+1]:=tmp;

    end;

    end;

    for i:=1 to 10 do

    write (a[i], ' ') ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Написать программу, которая в заданном одномерном массиве размерности N меняет местами соседние элементы, стоящие на чётных местах, с ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы