Задать вопрос
21 апреля, 20:58

Помогите составить программу и блок-схему к задаче: вычисление площади треугольника по формуле Герона.

+4
Ответы (1)
  1. 21 апреля, 22:08
    0
    Программа без контроля входных данных, т. е. треугольник должет существовать:

    var a, b, c, s, p:real;

    begin

    write ('a=') ; readln (a) ;

    write ('b=') ; readln (b) ;

    write ('c=') ; readln (c) ;

    p: = (a+b+c) / 2;

    s:=sqrt (p * (p-a) * (p-b) * (p-c)) ;

    writeln ('s=', s:6:2) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Помогите составить программу и блок-схему к задаче: вычисление площади треугольника по формуле Герона. ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы