Задать вопрос
27 февраля, 17:09

Реализовать с помощью 3-х циклов: while, repeat, for) Составить программу, которая выдавала бы сообщение ' true ', если последовательность из N целых чисел, вводимых с клавиатуры, является возрастающей

+1
Ответы (1)
  1. 27 февраля, 17:45
    0
    Это реализовано с помощью цикла for:

    Program p1;

    Var a1, a2, k, i:integer;

    Begin

    Write ('Введите число: ') ;

    Readln (a1) ;

    For i:=0 to 1 do

    Begin

    Write ('Введите число: ') ;

    Readln (a2) ;

    if a2>a1 then

    k:=k+1;

    a1:=a2;

    End;

    if k=2 then

    Writeln ('Эта последовательность является возрастающей') else

    Writeln ('Эта последовательность не является возрастающей') ;

    End.

    Это реализовано с помощью цикла while:

    Program p2;

    Var a1, a2, k, i:integer;

    Begin

    Write ('Введите число: ') ;

    Readln (a1) ;

    While i2 do

    Begin

    Write ('Введите число: ') ;

    Readln (a2) ;

    if a2>a1 then

    k:=k+1;

    a1:=a2;

    i:=i+1;

    End;

    if k=2 then Writeln ('Эта последовательность является возрастающей') else Writeln ('Эта последовательность не является возрастающей') ;

    End.

    Это реализовано с помощью цикла repeat:

    Program p3;

    Var a1, a2, k, i:integer;

    Begin

    Write ('Введите число: ') ;

    Readln (a1) ;

    repeat

    Begin

    i:=i+1;

    Write ('Введите число: ') ;

    Readln (a2) ;

    if a2>a1 then

    k:=k+1;

    a1:=a2;

    End;

    until i=2;

    if k=2 then

    Writeln ('Эта последовательность является возрастающей') else

    Writeln ('Эта последовательность не является возрастающей') ;

    End.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Реализовать с помощью 3-х циклов: while, repeat, for) Составить программу, которая выдавала бы сообщение ' true ', если последовательность ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы