Задать вопрос
13 ноября, 16:20

Дан массив из 20 действительных чисел. Напишите программу, которая складывает отдельно все положительные элементы этого массива, а отдельно отрицательные элементы и выдает на экран полученные результаты. Желательно подробную программу, буду всем благодарна)

+4
Ответы (1)
  1. 13 ноября, 16:40
    0
    Var A:array[1 ... 20]of real;

    B, C:real;

    i:byte;

    Begin

    WriteLn ('Введи элементы массива через пробел') ;

    For i: = 1 to 20 do

    Read (A[i]) ;

    For i: = 1 to 20 do

    if A[i]>0 then B:=B+A[i]

    else C:=C+A[i];

    WriteLn ('Сумма положительных элементов = ', B) ;

    WriteLn ('Сумма отрицательных = ', C)

    End.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Дан массив из 20 действительных чисел. Напишите программу, которая складывает отдельно все положительные элементы этого массива, а отдельно ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы