Задать вопрос
27 мая, 02:10

Для решения задачи задать случайным образом одномерный массив размерности N (вводится с клавиатуры) из целочисленных элементов, принадлежащих отрезку [-20; 20]. Вывести на экран промежуточные результаты, полученные при вычислении значения заданного выражения.

Составить программу для вычисления

T = (R / (Q+1)) + S

R - наименьший элемент массива;

Q - произведение элементов массива с нечетными номерами;

S - количество элементов, лежащих в интервале (A, B) (ввести с клавиатуры).

+2
Ответы (1)
  1. 27 мая, 02:46
    0
    Var C:array[1 ... 100] of Integer;

    i, N, Q, R, A, B:integer;

    T:real;

    begin

    Readln (N, A, B) ;

    For i:=1 to N do

    C[i]:=Random (-20,20) ;

    R:=C[1];

    Q:=1;

    For i:=1 to N do

    begin

    If C[i]
    R:=C[i];

    If C[i] mod 2=1 then

    Q:=Q*C[i];

    If (C[i]>A) and (C[i]
    S:=S+1;

    end;

    T: = (R / (Q+1)) + S;

    Writeln (R,' ', Q,' ', S,' ', T) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Для решения задачи задать случайным образом одномерный массив размерности N (вводится с клавиатуры) из целочисленных элементов, ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы