Задать вопрос
22 марта, 06:23

Сумма цифр.

Даны два числа А и В. Подсчитайте кол-во натуральных чисел на отрезке от А до В, сумма цифр которых четна.

Программа получает на вход два натуральных числа А и В, не превосходящих 10^9^ А<=В. Программа должна вывести одно число - кол-во натуральных чисел, больше или равных А и меньших или равных В, сумма цифр которых четна.

+3
Ответы (1)
  1. 22 марта, 08:23
    0
    Var n, j, i, a, b, c: integer;

    s: string;

    begin

    readln (a, b) ;

    for i : = a to b do

    begin

    s : = inttostr (i) ;

    for j : = 1 to length (s) do

    n : = n + strtoint (s[j]) ;

    if (n mod 2 = 0) then

    inc (c) ;

    end;

    writeln (c) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Сумма цифр. Даны два числа А и В. Подсчитайте кол-во натуральных чисел на отрезке от А до В, сумма цифр которых четна. Программа получает ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы