Задать вопрос
7 сентября, 20:43

Язык - Pascal. даны натуральное число n и последовательностьa1, ..., an. Составьте программу, которая находит среднее арифметическое тех элементов последовательности, которые кратны 3 и не кратны 9

+1
Ответы (1)
  1. 7 сентября, 23:13
    0
    Var

    n, i, s, a, k: integer;

    begin

    readln (n) ;

    s : = 0;

    k : = 0;

    for i : = 1 to n do

    begin

    read (a) ;

    if (a mod 3 = 0) and (a mod 9 0) then

    begin

    inc (k) ;

    inc (s, a) ;

    end;

    end;

    write (s div k) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Язык - Pascal. даны натуральное число n и последовательностьa1, ..., an. Составьте программу, которая находит среднее арифметическое тех ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы