Задать вопрос
10 января, 10:03

Написать программу, которая принимает на вход двухзначное число, а выводит на экран число, у которого цифры меняются местами.

Например, вводится число 37, а выводится 73.

Подсказка: используйте операторы div и mod.

+3
Ответы (1)
  1. 10 января, 10:19
    0
    Var n, m:integer;

    begin

    write ('n = ') ; readln (n) ;

    m: = (n mod 10) * 10 + n div 10;

    writeln ('m = ', m) ;

    end.

    Пример:

    n = 37

    m = 73
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Написать программу, которая принимает на вход двухзначное число, а выводит на экран число, у которого цифры меняются местами. Например, ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы