Задать вопрос
10 июля, 04:38

Информатика pascal abc

Pascal ABC задача номер 9 напишите программу вычисления y в зависимости от значения х у=1/х при х<0 у=2 х

10. напишите программу вычисления функций у=х^2, если - 2<=х<=2, у=4 в остальных случаях.

11. напишите программу вычисления суммы q и w, если q>w, в противном случая их разность

+2
Ответы (1)
  1. 10 июля, 05:45
    0
    Var x, y:real;

    begin

    write ('Введите х: ') ;

    readln (x) ;

    if x<0 then y:=1/x else y:=2*x;

    writeln ('y=', y)

    end.

    var x, y:real;

    begin

    write ('Введите х: ') ;

    readln (x) ;

    if (-2<=x) and (x<=2) then y:=x*x else y:=4;

    writeln ('y=', y)

    end.

    var q, w, x:real;

    begin

    write ('Введите q и w: ') ;

    readln (q, w) ;

    if q>w then x:=q+w else x:=q-w;

    writeln ('x=', x)

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Информатика pascal abc Pascal ABC задача номер 9 напишите программу вычисления y в зависимости от значения х у=1/х при х ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы