Задать вопрос
27 января, 16:03

Напишите программу в Паскале и объясните, как это делается

Сложить два 15-ти значных целых числа. При этом используют тип integer. Т. е. реализовать поэлементное сложение значений двух массивов с переносом разряда.

+5
Ответы (1)
  1. 27 января, 17:31
    0
    Const n=15;

    var a, b, c:array[0 ... n] of integer;

    s_a, s_b:string;

    i:integer;

    Begin

    readln (s_a) ;

    readln (s_b) ;

    while length (s_a)
    while length (s_b)
    for i : = n downto 1 do begin

    a[i]:=strtoint (s_a[i]) ;

    b[i]:=strtoint (s_b[i]) ;

    c[i]:=c[i]+a[i] + b[i];

    c[i-1]:=c[i] div 10;

    c[i]:=c[i] mod 10;

    end;

    writeln;

    for i: = 0 to n do write (a[i]) ;

    writeln;

    for i: = 0 to n do write (b[i]) ;

    writeln;

    for i: = 0 to n do write (c[i]) ;

    End.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Напишите программу в Паскале и объясните, как это делается Сложить два 15-ти значных целых числа. При этом используют тип integer. Т. е. ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы