Задать вопрос
16 сентября, 17:42

Задача 2. Напишите программу, которая в последовательности натуральных чисел определяет минимальное чётное число.

Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется четное число. Количество чисел не превышает 1000. Введенные числа не превышают 30 000. Программа должна вывести одно число-минимальное чётное число.

+4
Ответы (1)
  1. 16 сентября, 18:25
    0
    Var

    i, min, n, d: integer;

    begin

    readln (n) ;

    min:=30000;

    for i : = 1 to n do

    begin

    readln (d) ;

    if (d mod 2 = 0) and (min>d) then

    min:=d

    end;

    writeln (min) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Задача 2. Напишите программу, которая в последовательности натуральных чисел определяет минимальное чётное число. Программа получает на ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы