Задать вопрос
4 февраля, 04:33

Решить задачу в Паскале.

С клавиатуры вводится время суток в часах (от 1 до 24). Необходимо составить программу, которая будет выводить на экран привествие согласно введенному времени.

Ввод:

1

Вывод:

Доброй ночи

+5
Ответы (2)
  1. 4 февраля, 06:27
    0
    Program myp;

    var a:integer;

    begin

    readln (a) ;

    if a = 1 then writeln ('Доброй ночи') ;

    end.
  2. 4 февраля, 06:43
    0
    Var

    time : Integer; begin

    writeln ('Введите, который час: ') ;

    readln (time) ;

    if (time > 23) or (time < 0) then

    writeln ('Так не бывает!') else

    begin

    if (time > = 0) and (time < 6) then writeln ('Доброй ночи!') ;

    if (time > = 6) and (time < 12) then writeln ('Доброе утро!') ;

    if (time > = 12) and (time < 18) then writeln ('Добрый день!') ;

    if (time > = 18) and (time < 24) then writeln ('Добрый вечер!') ;

    end;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Решить задачу в Паскале. С клавиатуры вводится время суток в часах (от 1 до 24). Необходимо составить программу, которая будет выводить на ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы