Задать вопрос
4 марта, 11:28

Составить программу для решения следующей задачи: Дан массив целых чисел, заполненный случайными числами в диапазоне [-100, 100]. Замените все отрицательные элементы максимальным. Выведите на экран исходный и измененный массивы.

+4
Ответы (1)
  1. 4 марта, 12:24
    0
    var

    i, max:integer;

    ar:array[0 ... 200] of integer;

    begin

    randomize;

    max:=0;

    for i:=1 to 200 do begin

    ar[i]:=random (200+1) - 100;

    if (ar[i] > max) then max:=ar[i];

    if (i mod 20=0) then writeln (ar[i]) else write (ar[i],' ') ;

    end;

    writeln () ;

    for i:=1 to 200 do begin

    if (ar[i] < 0) then ar[i]:=max;

    if (i mod 20=0) then writeln (ar[i]) else write (ar[i],' ') ;

    end;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Составить программу для решения следующей задачи: Дан массив целых чисел, заполненный случайными числами в диапазоне [-100, 100]. Замените ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы