Задать вопрос
22 февраля, 21:04

Числа

Вам даны число N и цифра D. Выведите все N - значные числа, которые не содержат цифру D, в возрастающем порядке.

Формат входных данных

В единственной строке входного файла записаны число N (1 ≤ N ≤ 7) и цифра D (0 ≤ D ≤ 9).

Формат выходных данных

В выходном файле выведите все N - значные числа, которые не содержат цифру D, по одному в одной строке.

+1
Ответы (1)
  1. 22 февраля, 22:00
    0
    Uses crt;

    var n, d, z, x, c, k, a, b:integer;

    begin

    write ('N:') ; readln (n) ;

    write ('D:') ; readln (d) ;

    a:=round (power (10, n-1)) ;

    b:=round (power (10, n) - 1) ;

    for x:=a to b do

    begin

    z:=x;

    k:=0;

    while z>0 do

    begin

    c:=z mod 10;

    if c=d then inc (k) ;

    z:=z div 10;

    end;

    if k=0 then writeln (x) ;

    end;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Числа Вам даны число N и цифра D. Выведите все N - значные числа, которые не содержат цифру D, в возрастающем порядке. Формат входных ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы