Задать вопрос
19 мая, 01:45

Петр, когда едет на турнир, всегда берет с собой шоколадку прямоугольной формы для восстановления сил. Определите скольким друзьям достанется шоколадка, если ее сначала разломали N раз, а затем каждую образовавшуюся часть поделили K раз.

Входные данные:

Входной поток содержит единственную строку из двух цифр N и K разделенных пробелом (0 ≤ N, K ≤ 2147483647)

Выходные данные:

Выходной поток содержит единственное целое число - количество кусочков шоколадки.

+5
Ответы (1)
  1. 19 мая, 04:19
    0
    Var s, n, k, p:integer;

    begin

    write ('введите n и k: ') ;

    read (n, k) ;

    if n>=0 then s:=s+1;

    if (k=0) then s:=s+1;

    if s=2 then p: = (n+1) * (k+1) else writeln;

    write (p) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Петр, когда едет на турнир, всегда берет с собой шоколадку прямоугольной формы для восстановления сил. Определите скольким друзьям ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы