Задать вопрос
20 января, 12:02

Решите в Паскаль ABC

Составить программу, решающую следующую задачу: Вы покупаете товар, и у Вас

имеются монеты номиналом 1, 2, 5, 10 рублей. Наберите необходимую сумму товара в

N рублей так, чтобы она состояла из минимального

количества монет.

+4
Ответы (1)
  1. 20 января, 15:11
    0
    Var a: integer;

    begin

    readln (a) ;

    writeln (a div 10, 'x10, ', a mod 10 div 5, 'x5, ', a mod 10 mod 5 div 2, 'x2, ', a mod 50 mod 5 mod 2 div 1, 'x1') ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Решите в Паскаль ABC Составить программу, решающую следующую задачу: Вы покупаете товар, и у Вас имеются монеты номиналом 1, 2, 5, 10 ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы