Задать вопрос
6 января, 09:43

Значение переменных x, y, z поменять местами так, чтобы они были упорядочены по возрастанию. (написать программу в Паскале)

+4
Ответы (1)
  1. 6 января, 12:01
    0
    Var

    max, min, x, y, z:integer;

    begin

    readln (x, y, z) ;

    //Найдём максимум

    if (x>y) AND (x>z) then

    max:=x

    else

    if (y>x) AND (y>z) then

    max:=y

    else

    max:=z;

    //Найдём минимум

    if (x
    min:=x

    else

    if (y
    min:=y

    else

    min:=z;

    //Результат

    if (xmin) AND (xmax) then

    writeln (min,' ', x,' ', max)

    else

    if (ymin) AND (ymax) then

    writeln (min,' ', y,' ', max)

    else

    writeln (min,' ', z,' ', max)

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Значение переменных x, y, z поменять местами так, чтобы они были упорядочены по возрастанию. (написать программу в Паскале) ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы