Задать вопрос
9 октября, 23:16

Составьте программу, Дано количество информации в битах. Вывести в удобной форме в более крупных единицах. (до Мб).

Пример вывода:

10240 бит = 1280 байт = 1,25 Кб = 0,0012 Мб

+2
Ответы (1)
  1. 10 октября, 00:12
    0
    Var

    n:integer;

    begin

    read (n) ;

    write (n,' бит = ', n/8, ' байт = ', n/8192:0:2,' Кб = ', n / (8*sqr (1024)) : 0:4,' Мб') ;

    end.

    Альтернативное решение:

    var

    n: integer;

    b, kb, mb: real;

    begin

    read (n) ;

    b : = n / 8;

    kb : = b / 1024;

    mb : = kb / 1024;

    write (n, ' бит = ', b:0, ' байт = ', kb:0:2, ' Кб = ', mb:0:4, ' Мб') ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Составьте программу, Дано количество информации в битах. Вывести в удобной форме в более крупных единицах. (до Мб). Пример вывода: 10240 ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы