Задать вопрос
30 декабря, 10:44

По данному натуральному n вычислите сумму 12+22 + ... + n2.

Входные данные

Вводится единственное число n.

Выходные данные

Необходимо вывести вычисленную сумму.

Примеры

входные данные

2

выходные данные

5

+2
Ответы (1)
  1. 30 декабря, 13:10
    0
    var a, i, r: integer;

    begin read (a) ;

    r:=0.;

    for i:=1 to a do

    r:=r+i*i;

    write (r) ;

    readln;

    readln

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «По данному натуральному n вычислите сумму 12+22 + ... + n2. Входные данные Вводится единственное число n. Выходные данные Необходимо ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы