Задать вопрос
10 декабря, 04:41

Написать программу на Паскале, которая выведет на экран те строки из текстового файла, которые являются палиндромами. Имя файла вводить с клавиатуры.

+1
Ответы (1)
  1. 10 декабря, 08:18
    0
    Program proga_25_3;

    var

    A: text;

    s, p : string;

    i:integer;

    f:boolean;

    begin

    write ('Введите имя и путь к файлу ') ;

    read (p) ;

    assign (A, p) ;

    reset (A) ;

    while not eof (A) do

    begin

    readln (A, s) ;

    for i:=1 to length (s) div 2 do

    if s[i]=s[length (s) - i+1] then

    f:=true

    else

    begin

    f:=false;

    break;

    end;

    if f then

    writeln (S) ;

    end;

    close (A) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Написать программу на Паскале, которая выведет на экран те строки из текстового файла, которые являются палиндромами. Имя файла вводить с ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы