Задать вопрос
3 мая, 12:59

Помогите написать программу на Паскале.

Напишите программу, которая в последовательности целых чисел

вычисляет сумму всех чисел, которые кратны 6 или 11. Программа получает на вход

целые числа, количество введённых чисел неизвестно, последовательность чисел

заканчивается числом 0 (0 - признак окончания ввода, не входит

в последовательность).

Количество чисел не превышает 1000. Введённые числа по

модулю не превышают 30 000.

Программа должна вывести одно число: сумму всех чисел,

которые кратны 6 или 11.

+3
Ответы (1)
  1. 3 мая, 14:36
    0
    Uses crt;

    var a, sum:integer;

    begin

    sum:=0;

    repeat

    read (a) ;

    if (a mod 6=0) or (a mod 11=0) then sum:=sum+a;

    until a=0;

    writeln (sum) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Помогите написать программу на Паскале. Напишите программу, которая в последовательности целых чисел вычисляет сумму всех чисел, которые ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы