Задать вопрос
29 декабря, 20:25

укажите наибольшее из таких чисел x, при вводе которых алгоритм печатает сначала 3, а потом 25.

program B08;

var x, a, b: interger;

begin

readln (x) ;

a:=0; b:=0;

while x>0 do

begin

a:=a+1;

if (x mod 2) then

b: = b + (x mod 10) ;

x:=x div 10;

end;

writeln (a) ; write (b;

end.

+1
Ответы (1)
  1. 30 декабря, 00:14
    0
    Ответ: 997

    Программу правильно допиши:

    var x, a, b: integer;

    begin

    readln (x) ;

    a:=0; b:=0;

    while x>0 do

    begin

    a:=a+1;

    if (x mod 2) b then

    b: = b + (x mod 10) ;

    x:=x div 10;

    end;

    writeln (a) ; write (b) ;

    end.

    (исправленный вид)
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «укажите наибольшее из таких чисел x, при вводе которых алгоритм печатает сначала 3, а потом 25. program B08; var x, a, b: interger; begin ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы