Задать вопрос
7 февраля, 07:51

Помогите составить программу в Paskal!

1) Вычислите значение минимального элемента массива

2) Вычислите сумму минисального и максимального элементов

3) Выведите номер минимального элемента

4) Выведите номера максимальных элементов и их количество

+3
Ответы (1)
  1. 7 февраля, 08:10
    0
    Номера минимума и максимума не получается сделать паскаль выделывается чо то

    var a: array[1 ... 5] of integer; i, min, max, summa, nmin, nmax:integer; begin

    for i: = 1 to 5 do readln (a[i]) ;

    min:=a[1]; for i: = 2 to 5 dobeginif a[i]
    end;

    max:=a[1]; for i: = 2 to 5 dobeginif a[i]>a[1] then max:=a[i]; end; summa:=min+max;

    writeln ('min=', min) ; writeln ('min+max=', summa) ; writeln ('nomer min=', nmin) ; writeln ('nomer mmax=', nmax) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Помогите составить программу в Paskal! 1) Вычислите значение минимального элемента массива 2) Вычислите сумму минисального и максимального ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы