Задать вопрос
25 сентября, 23:47

Напишите программу на языке Паскаль для решения следующей задачи:

Дан массив вещественных чисел из 10 элементов. Поменять в нем первый элемент массива с последним.

Пример:

Входные данные:

2,3,-4,5,-6,2,-5,7,-9,-3

Выходные данные:

-3,3,-4,5,-6,2,-5,7,-9,2

+5
Ответы (1)
  1. 26 сентября, 01:58
    0
    Program g;

    const n = 10;

    var a:array [1 ... n] of real;

    i:integer;

    s: real;

    begin

    for i:=1 to n do

    read (a[i]) ;

    s: = a[1];

    a[1]:=a[10];

    a[10]:=s;

    for i:=1 to n do

    write (a[i]+',') ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Напишите программу на языке Паскаль для решения следующей задачи: Дан массив вещественных чисел из 10 элементов. Поменять в нем первый ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы