Задать вопрос
31 декабря, 02:13

Задача А

Число Фибоначчи это числовая последовательность, в которой первые два числа единицы, а каждое последующее равно сумме двух предыдущих. Дано натуральное число N (2< N < 2*10^9). Найти два ближайших к нему числа Фибоначчи. Одно из них меньше N, другое больше N. Вывести их в порядке возрастания. Входные данные:

В первой строке входного файла Input. txt содержится одно натуральное число N.

Выходные данные:

В выходной файл Output. txt вывести два ближайших к N числа Фибоначчи.

+4
Ответы (1)
  1. 31 декабря, 06:06
    0
    Var

    a, b, n:integer;

    begin

    read (n) ;

    a : = 0;

    b : = 1;

    while b < n do

    begin

    b : = a + b;

    a : = b - a;

    end;

    write (a,' ', b)

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Задача А Число Фибоначчи это числовая последовательность, в которой первые два числа единицы, а каждое последующее равно сумме двух ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы