Задать вопрос
16 июля, 22:25

Определите, количество чисел K, для которых следующая программа выведет такой же результат, что и для K = 22:

var i, k: integer;

function F (x:integer) : integer;

begin

F:=x*x*x+x*x;

end;

begin

i : = 20;

readln (K) ;

while (i > 0) and (F (i) > K) do

i:=i-1;

writeln (i) ;

end.

+3
Ответы (1)
  1. 17 июля, 00:45
    0
    У тебя функция x^3+x^2 и перебор от 20 до 1, т. е. x^3+x^2 будет больше 22 при числах:

    20, 19, 18, 17, 16, 15, 14, 13, 12, 11, 10, 9, 8, 7, 6, 5, 4, 3.

    итого: 18 чисел
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Определите, количество чисел K, для которых следующая программа выведет такой же результат, что и для K = 22: var i, k: integer; function F ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы