Задать вопрос
22 июня, 18:05

Составить программу которая заменяет все нечетные числа на 31 массив из 15 целых чисел формируется случайным образом в интервале [20; 30]

+1
Ответы (1)
  1. 22 июня, 20:48
    0
    Program Task;

    Const n = 15;

    Var a: Array [1 ... n] of Integer;

    i: Integer;

    Begin

    Randomize;

    For i : = 1 To n Do

    a[i] : = Random (30 - 20 + 1) + 20;

    WriteLn ('Массив:') ;

    For i : = 1 To n Do

    Write (a[i], ' ') ;

    WriteLn;

    For i : = 1 To n Do

    If a[i] Mod 2 = 1 Then

    a[i] : = 31;

    WriteLn ('Результат:') ;

    For i : = 1 To n Do

    Write (a[i], ' ') ;

    ReadLn;

    End.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Составить программу которая заменяет все нечетные числа на 31 массив из 15 целых чисел формируется случайным образом в интервале [20; 30] ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы