Задать вопрос
25 августа, 20:56

Написать программу в паскалabc

Даны 3 числа. Определить, можно ли построить треугольник с указанными сторонами.

+5
Ответы (1)
  1. 25 августа, 21:04
    0
    Program triangle;

    var

    max, a, b, c, s:integer;

    begin

    readln (a, b, c) ;

    max:=a;

    if b > max then begin

    max:=b;

    s:=a+c;

    if s > max then writeln ('Мoжно')

    else

    writeln ('Нельзя') ;

    end;

    if c > max then begin

    max:=c;

    s:=a+b;

    if s > max then writeln ('Мoжно')

    else

    writeln ('Нельзя') ;

    end

    else

    s:=c+b;

    if s > max then writeln ('Мoжно')

    else writeln ('Нельзя') ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Написать программу в паскалabc Даны 3 числа. Определить, можно ли построить треугольник с указанными сторонами. ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы